summaryrefslogtreecommitdiff
path: root/tools/build_release
diff options
context:
space:
mode:
authorYaroslav Halchenko <debian@onerussian.com>2014-06-14 13:34:18 +0200
committerYaroslav Halchenko <debian@onerussian.com>2014-06-14 13:34:18 +0200
commit9f010b1561421d8b3e128e07b50de9919955f258 (patch)
tree8b692a5cc9abe7024da3a6809f5c5dc5b7c6b7b6 /tools/build_release
nitime (0.5-1) unstable; urgency=medium
* New release - does not ship sphinxext/inheritance_diagram.py any longer (Closes: #706533) * debian/copyright - extended to cover added 3rd party snippets and updated years * debian/watch - updated to use githubredir.debian.net service * debian/patches - debian/patches/up_version_info_python2.6 for compatibility with python2.6 (on wheezy etc) # imported from the archive
Diffstat (limited to 'tools/build_release')
-rwxr-xr-xtools/build_release31
1 files changed, 31 insertions, 0 deletions
diff --git a/tools/build_release b/tools/build_release
new file mode 100755
index 0000000..00c16ab
--- /dev/null
+++ b/tools/build_release
@@ -0,0 +1,31 @@
+#!/usr/bin/env python
+"""Nitime release build script.
+"""
+from toollib import *
+
+# Find our directory and go one above, regardless of where we were called from
+my_dir = os.path.split(os.path.abspath(__file__))[0]
+cd(pjoin(my_dir, '..'))
+
+# Load release info
+execfile(pjoin('nitime','version.py'))
+
+# Check that everything compiles
+compile_tree()
+
+# Cleanup
+for d in ['build','dist', pjoin('doc','_build'), pjoin('docs','dist')]:
+ if os.path.isdir(d):
+ remove_tree(d)
+
+# Build source and binary distros
+sh('./setup.py sdist --formats=gztar,zip')
+
+# Build eggs
+sh('python ./setup_egg.py bdist_egg')
+
+# Create a windows distribution
+# sh("python setup.py bdist_wininst")
+
+# Change name so retarded Vista runs the installer correctly
+# sh("rename 's/linux-i686/win32-setup/' dist/*.exe")