summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Hartman <hartmans@debian.org>2021-08-26 13:11:39 -0600
committerSteve Langasek <steve.langasek@canonical.com>2021-09-15 17:52:40 -0700
commitaee2095b9a13a3abde1ba39f891a60918f112686 (patch)
treee02978dfd845fb513877f07c27f7186a75577752
parent01dd10ca3efd89193c3f0429064b54bc09501eec (diff)
libpam0g.postinst: fix syntax error in systemd unit restart
-rw-r--r--debian/changelog7
-rw-r--r--debian/libpam0g.postinst2
2 files changed, 8 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index dee3f32b..0447e49a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+pam (1.4.0-10) UNRELEASED; urgency=medium
+
+ * Fix syntax error in libpam0g.postinst when a systemd unit fails,
+ Closes: #992538
+
+ -- Sam Hartman <hartmans@debian.org> Thu, 26 Aug 2021 13:11:23 -0600
+
pam (1.4.0-9) unstable; urgency=medium
* Revert prefer the multiarch path from 1.4.0-8: It turns out that
diff --git a/debian/libpam0g.postinst b/debian/libpam0g.postinst
index 396b35ca..6279f684 100644
--- a/debian/libpam0g.postinst
+++ b/debian/libpam0g.postinst
@@ -60,7 +60,7 @@ if test -d /run/systemd/system; then
if systemctl try-restart $1; then
:
else
- failed = "$failed $1"
+ failed="$failed $1"
fi
}
else # not systemd