summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mraz <tmraz@fedoraproject.org>2019-01-04 12:36:13 +0100
committerTomas Mraz <tmraz@fedoraproject.org>2019-01-04 12:36:13 +0100
commitbe49469b9119767158bc5306f4085c366751c56b (patch)
tree9d5cc7582f681a40d5dd99c7c204e9b5ac4a2db9
parent91d4678388b2a7d768ee2ec8cc569e11fc223ffd (diff)
Fix regressions from the last commits.
* configure.ac: Test for logwtmp needs -lutil in LIBS. * modules/Makefile.am: Fix indentation of variable assignments causing creation of incorrect Makefile.
-rw-r--r--configure.ac3
-rw-r--r--modules/Makefile.am4
2 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4d1b1965..e9d44769 100644
--- a/configure.ac
+++ b/configure.ac
@@ -534,7 +534,10 @@ AC_CHECK_FUNCS(getutent_r getpwnam_r getpwuid_r getgrnam_r getgrgid_r getspnam_r
AC_CHECK_FUNCS(getgrouplist getline getdelim)
AC_CHECK_FUNCS(inet_ntop inet_pton innetgr)
AC_CHECK_FUNCS([ruserok_af ruserok], [break])
+BACKUP_LIBS=$LIBS
+LIBS="$LIBS -lutil"
AC_CHECK_FUNCS([logwtmp])
+LIBS=$BACKUP_LIBS
AM_CONDITIONAL([COND_BUILD_PAM_RHOSTS], [test "$ac_cv_func_ruserok_af" = yes -o "$ac_cv_func_ruserok" = yes])
AM_CONDITIONAL([COND_BUILD_PAM_LASTLOG], [test "$ac_cv_func_logwtmp" = yes])
diff --git a/modules/Makefile.am b/modules/Makefile.am
index b98dc5c8..612fc740 100644
--- a/modules/Makefile.am
+++ b/modules/Makefile.am
@@ -3,11 +3,11 @@
#
if COND_BUILD_PAM_RHOSTS
- MAYBE_PAM_RHOSTS = pam_rhosts
+ MAYBE_PAM_RHOSTS = pam_rhosts
endif
if COND_BUILD_PAM_LASTLOG
- MAYBE_PAM_LASTLOG = pam_lastlog
+ MAYBE_PAM_LASTLOG = pam_lastlog
endif
SUBDIRS := pam_access pam_cracklib pam_debug pam_deny pam_echo \