summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2006-06-15 19:14:12 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2006-06-15 19:14:12 +0000
commitdba6cd9abf46b7368c43e668513cf6734b3c41d1 (patch)
tree876a214449e5ab4d13ab6a9f378a71a0bc494568
parentf1ab2098f913a9f200787a9e9011cb80f11a30f2 (diff)
Relevant BUGIDs:
Purpose of commit: bugfix Commit summary: --------------- The Intel C Compiler (icc) claims to be gcc compatible, but trys to interprets unknown options without error with fatal results... 2006-06-15 Thorsten Kukuk <kukuk@thkukuk.de> * configure.in: Add special exceptions for icc: different compiler warnings, no PIE support.
-rw-r--r--ChangeLog5
-rw-r--r--configure.in21
2 files changed, 24 insertions, 2 deletions
diff --git a/ChangeLog b/ChangeLog
index 0923a816..24f437c5 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,8 @@
+2006-06-15 Thorsten Kukuk <kukuk@thkukuk.de>
+
+ * configure.in: Add special exceptions for icc: different
+ compiler warnings, no PIE support.
+
2006-06-14 Thorsten Kukuk <kukuk@thkukuk.de>
* libpam/pam_misc.c (_pam_strdup): Use strlen and strcpy.
diff --git a/configure.in b/configure.in
index 23faeab6..f265b835 100644
--- a/configure.in
+++ b/configure.in
@@ -71,7 +71,7 @@ AC_PROG_LIBTOOL
# Largefile support
AC_SYS_LARGEFILE
-if eval "test x$GCC = xyes"; then
+if eval "test x$GCC = xyes -a $CC != icc"; then
for flag in \
-W \
-Wall \
@@ -90,6 +90,23 @@ if eval "test x$GCC = xyes"; then
JAPHAR_GREP_CFLAGS($flag, [ CFLAGS="$CFLAGS $flag" ])
done
fi
+if eval "test x$CC = xicc"; then
+ for flag in \
+ -Wall \
+ -Wmissing-prototypes \
+ -Wpointer-arith \
+ -Wreturn-type \
+ -Wstrict-prototypes \
+ -Wwrite-strings \
+ -Wshadow \
+ -Wp64 \
+ -Wdeprecated \
+ -Wuninitialized \
+ -Wmain
+ do
+ JAPHAR_GREP_CFLAGS($flag, [ CFLAGS="$CFLAGS $flag" ])
+ done
+fi
AC_C___ATTRIBUTE__
@@ -158,7 +175,7 @@ AC_CACHE_CHECK(for -fpie, libc_cv_fpie, [dnl
int foo;
main () { return 0;}
EOF
- if test "$USE_PIE" = "yes" &&
+ if test "$USE_PIE" = "yes" -a "$CC" != "icc" &&
AC_TRY_COMMAND([${CC-cc} $CFLAGS $CPPFLAGS $LDFLAGS -pie -fpie
-o conftest conftest.c 1>&AS_MESSAGE_LOG_FD])
then