summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2010-07-29 20:16:39 -0700
committerSteve Langasek <vorlon@debian.org>2019-01-08 21:32:38 -0800
commit655c7a8843261079fecf0b6e15de77972a0eb708 (patch)
tree167aeb717538bdc9f685a652009038d586530779 /debian/rules
parent6ce511785e4b9751ef184236c2cf8f63bc25f512 (diff)
parent8645d4f5131d25692dfd78d3e1c46b03f33febf3 (diff)
merge from trunk
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 3 insertions, 7 deletions
diff --git a/debian/rules b/debian/rules
index c70cbc42..7f4ed318 100755
--- a/debian/rules
+++ b/debian/rules
@@ -35,7 +35,9 @@ override_dh_compress:
# .install files don't have "except for" handling, so we need to exclude
# our module that doesn't match right here
override_dh_install:
+ifneq (,$(findstring libpam-modules, $(shell dh_listpackages)))
dh_install -plibpam-modules -Xpam_cracklib
+endif
dh_install -Nlibpam-modules
# again, excluding files by hand; also, build our local manpage for pam_getenv
@@ -56,13 +58,7 @@ override_dh_link:
# dh_fixperms doesn't want
override_dh_fixperms:
dh_fixperms
-ifeq (,$(findstring -i, $(DH_INTERNAL_OPTIONS)))
+ifneq (,$(findstring libpam-modules, $(shell dh_listpackages)))
chgrp shadow $(d)/libpam-modules-bin/sbin/unix_chkpwd
chmod 02755 $(d)/libpam-modules-bin/sbin/unix_chkpwd
endif
-
-# ideally, dh_makeshlibs could compute this from the symbols file; or we
-# could drop it since anyone building against this package should have a
-# dpkg-shlibdeps available that knows about symbols files?
-override_dh_makeshlibs:
- dh_makeshlibs -V "libpam0g (>= 1.1.0)"