summaryrefslogtreecommitdiff
path: root/modules/pam_pwhistory
diff options
context:
space:
mode:
authorDmitry V. Levin <ldv@altlinux.org>2020-08-07 18:00:00 +0000
committerDmitry V. Levin <ldv@altlinux.org>2020-08-07 18:00:00 +0000
commitc0b3c9fa05424f9606b0c348e0052bfb3bda3fa9 (patch)
tree6a7a0ac7a1abcec8c3f59c8a4bf83f96ee50e7d9 /modules/pam_pwhistory
parent0ca78051452625ec7c30f51f9408ea4c40de713e (diff)
build: rename PIE_* AC_SUBST variables to EXE_*
There are going to be other options added to CFLAGS and LDFLAGS of executables made along with modules. * configure.ac (EXE_CFLAGS, EXE_LDFLAGS): New variables initialized from PIE_CFLAGS and PIE_LDFLAGS, respectively. AC_SUBST them instead of PIE_CFLAGS and PIE_LDFLAGS. All users updated.
Diffstat (limited to 'modules/pam_pwhistory')
-rw-r--r--modules/pam_pwhistory/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/modules/pam_pwhistory/Makefile.am b/modules/pam_pwhistory/Makefile.am
index 32b9fcc4..8a4dbcb2 100644
--- a/modules/pam_pwhistory/Makefile.am
+++ b/modules/pam_pwhistory/Makefile.am
@@ -34,9 +34,9 @@ pam_pwhistory_la_LIBADD = $(top_builddir)/libpam/libpam.la @LIBCRYPT@ @LIBSELINU
pam_pwhistory_la_SOURCES = pam_pwhistory.c opasswd.c
sbin_PROGRAMS = pwhistory_helper
-pwhistory_helper_CFLAGS = $(AM_CFLAGS) -DHELPER_COMPILE=\"pwhistory_helper\" @PIE_CFLAGS@
+pwhistory_helper_CFLAGS = $(AM_CFLAGS) -DHELPER_COMPILE=\"pwhistory_helper\" @EXE_CFLAGS@
pwhistory_helper_SOURCES = pwhistory_helper.c opasswd.c
-pwhistory_helper_LDFLAGS = @PIE_LDFLAGS@
+pwhistory_helper_LDFLAGS = @EXE_LDFLAGS@
pwhistory_helper_LDADD = $(top_builddir)/libpam/libpam.la @LIBCRYPT@
if ENABLE_REGENERATE_MAN