summaryrefslogtreecommitdiff
path: root/modules/pam_timestamp/Makefile.am
diff options
context:
space:
mode:
authorDmitry V. Levin <ldv@altlinux.org>2020-05-03 01:18:44 +0000
committerDmitry V. Levin <ldv@altlinux.org>2020-05-03 12:21:11 +0000
commitd37f70b2dcb813311199200598ee6d4fc1ada52b (patch)
treee08c0085c72f3ed17392bd14db642552fea2f142 /modules/pam_timestamp/Makefile.am
parentf0f35e79d4d5c98e58955a37673b48ea299657ba (diff)
modules/pam_timestamp/Makefile.am: rename noinst_PROGRAMS to check_PROGRAMS
... and remove nodist_TESTS. * modules/pam_timestamp/Makefile.am (nodist_TESTS): Remove. (TESTS): Replace $(nodist_TESTS) with $(check_PROGRAMS). (noinst_PROGRAMS): Rename to check_PROGRAMS.
Diffstat (limited to 'modules/pam_timestamp/Makefile.am')
-rw-r--r--modules/pam_timestamp/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/modules/pam_timestamp/Makefile.am b/modules/pam_timestamp/Makefile.am
index a101805f..1aee259b 100644
--- a/modules/pam_timestamp/Makefile.am
+++ b/modules/pam_timestamp/Makefile.am
@@ -13,8 +13,7 @@ man_MANS = pam_timestamp.8 pam_timestamp_check.8
endif
XMLS = README.xml pam_timestamp.8.xml pam_timestamp_check.8.xml
dist_check_SCRIPTS = tst-pam_timestamp
-nodist_TESTS = hmacfile
-TESTS = $(dist_check_SCRIPTS) $(nodist_TESTS)
+TESTS = $(dist_check_SCRIPTS) $(check_PROGRAMS)
securelibdir = $(SECUREDIR)
secureconfdir = $(SCONFIGDIR)
@@ -44,7 +43,7 @@ pam_timestamp_check_LDFLAGS = @PIE_LDFLAGS@
hmacfile_SOURCES = hmacfile.c hmacsha1.c sha1.c
hmacfile_LDADD = $(top_builddir)/libpam/libpam.la
-noinst_PROGRAMS = hmacfile
+check_PROGRAMS = hmacfile
if ENABLE_REGENERATE_MAN
noinst_DATA = README