summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--configure.ac2
-rw-r--r--modules/Makefile.am6
-rw-r--r--modules/pam_userdb/Makefile.am12
3 files changed, 10 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 6ccc1775..f3ef8372 100644
--- a/configure.ac
+++ b/configure.ac
@@ -454,7 +454,6 @@ if test x"$WITH_DB" != xno ; then
fi
fi
AC_SUBST(LIBDB)
-AM_CONDITIONAL([HAVE_LIBDB], [test -n "$LIBDB"])
AC_ARG_ENABLE([nis],
AS_HELP_STRING([--disable-nis], [Disable building NIS/YP support in pam_unix]))
@@ -662,6 +661,7 @@ AM_CONDITIONAL([COND_BUILD_PAM_LASTLOG], [test "$ac_cv_func_logwtmp" = yes])
AM_CONDITIONAL([COND_BUILD_PAM_RHOSTS], [test "$ac_cv_func_ruserok_af" = yes -o "$ac_cv_func_ruserok" = yes])
AM_CONDITIONAL([COND_BUILD_PAM_SETQUOTA], [test "$ac_cv_func_quotactl" = yes])
AM_CONDITIONAL([COND_BUILD_PAM_TTY_AUDIT], [test "$HAVE_AUDIT_TTY_STATUS" = yes])
+AM_CONDITIONAL([COND_BUILD_PAM_USERDB], [test -n "$LIBDB"])
dnl Files to be created from when we run configure
AC_CONFIG_FILES([Makefile libpam/Makefile libpamc/Makefile libpamc/test/Makefile \
diff --git a/modules/Makefile.am b/modules/Makefile.am
index fc75fe64..3ba750cd 100644
--- a/modules/Makefile.am
+++ b/modules/Makefile.am
@@ -26,6 +26,10 @@ if COND_BUILD_PAM_TTY_AUDIT
MAYBE_PAM_TTY_AUDIT = pam_tty_audit
endif
+if COND_BUILD_PAM_USERDB
+ MAYBE_PAM_USERDB = pam_userdb
+endif
+
SUBDIRS := \
pam_access \
$(MAYBE_PAM_CRACKLIB) \
@@ -68,7 +72,7 @@ SUBDIRS := \
$(MAYBE_PAM_TTY_AUDIT) \
pam_umask \
pam_unix \
- pam_userdb \
+ $(MAYBE_PAM_USERDB) \
pam_usertype \
pam_warn \
pam_wheel \
diff --git a/modules/pam_userdb/Makefile.am b/modules/pam_userdb/Makefile.am
index d62fc54c..ca11d0e2 100644
--- a/modules/pam_userdb/Makefile.am
+++ b/modules/pam_userdb/Makefile.am
@@ -7,12 +7,10 @@ MAINTAINERCLEANFILES = $(MANS) README
EXTRA_DIST = README $(XMLS) pam_userdb.8 create.pl tst-pam_userdb
-if HAVE_LIBDB
if HAVE_DOC
- man_MANS = pam_userdb.8
-endif
- TESTS = tst-pam_userdb
+man_MANS = pam_userdb.8
endif
+TESTS = tst-pam_userdb
XMLS = README.xml pam_userdb.8.xml
@@ -26,10 +24,8 @@ if HAVE_VERSIONING
AM_LDFLAGS += -Wl,--version-script=$(srcdir)/../modules.map
endif
-if HAVE_LIBDB
- securelib_LTLIBRARIES = pam_userdb.la
- pam_userdb_la_LIBADD = $(top_builddir)/libpam/libpam.la
-endif
+securelib_LTLIBRARIES = pam_userdb.la
+pam_userdb_la_LIBADD = $(top_builddir)/libpam/libpam.la
noinst_HEADERS = pam_userdb.h