summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-11-29 02:03:09 +0000
committerfiddlosopher <fiddlosopher@788f1e2b-df1e-0410-8736-df70ead52e1b>2007-11-29 02:03:09 +0000
commit8589f118d84ab137ae8673634baf7e3edc087c88 (patch)
tree7160d7dd45efe20485493d4f049002081c738739 /Makefile
parentae5697e3b4b4836023ae868196758e692a9843f8 (diff)
Makefile changes: BUILDCONF and CABAL_BKP.
+ Changed BUILDCONF to point to dist/setup-config, not .setup-config. This is where current versions of Cabal put it. 'make clean' works again! + Do not clean up CABAL_BKP, because it might need to be recovered for a new build with a different GHC version. git-svn-id: https://pandoc.googlecode.com/svn/trunk@1108 788f1e2b-df1e-0410-8736-df70ead52e1b
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 99581e610..63245feea 100644
--- a/Makefile
+++ b/Makefile
@@ -8,7 +8,7 @@ SRCDIR := .
MANDIR := man
TESTDIR := tests
BUILDDIR := dist
-BUILDCONF := .setup-config
+BUILDCONF := $(BUILDDIR)/setup-config
BUILDVARS := vars
CONFIGURE := configure
@@ -118,7 +118,6 @@ $(WRAPPERS): %: $(SRCDIR)/wrappers/%.in $(SRCDIR)/wrappers/*.sh
@$(generate-shell-script)
CABAL_BACKUP=$(CABAL).orig
-cleanup_files+=$(CABAL_BACKUP)
$(CABAL_BACKUP):
cp $(CABAL) $(CABAL_BACKUP) ; \
if echo $(GHC_VERSION) | grep -q '^6.6'; then \