summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile15
-rw-r--r--pandoc.cabal3
2 files changed, 16 insertions, 2 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000..99588c157
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,15 @@
+makemanpages=$(shell find dist -type f -name make-pandoc-man-pages | head -1)
+MANPAGES=man/man1/pandoc.1 man/man5/pandoc_markdown.5
+
+all: ${MANPAGES}
+
+%.1: %.1.template
+ ${makemanpages}
+
+%.5: %.5.template
+ ${makemanpages}
+
+clean:
+ -rm ${MANPAGES}
+
+.PHONY: all clean
diff --git a/pandoc.cabal b/pandoc.cabal
index 0b6c71919..c9feb3272 100644
--- a/pandoc.cabal
+++ b/pandoc.cabal
@@ -86,6 +86,7 @@ Extra-Source-Files:
-- documentation
INSTALL, BUGS, CONTRIBUTING.md, changelog
-- code to create pandoc.1 man page
+ Makefile
man/man1/pandoc.1.template
man/man5/pandoc_markdown.5.template
-- generated man pages (produced post-build)
@@ -173,8 +174,6 @@ Extra-Source-Files:
tests/epub/*.epub
tests/epub/*.native
tests/txt2tags.t2t
-Extra-Tmp-Files: man/man1/pandoc.1
- man/man5/pandoc_markdown.5
Source-repository head
type: git