summaryrefslogtreecommitdiff
path: root/web/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'web/Makefile')
-rw-r--r--web/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/web/Makefile b/web/Makefile
index 644ce61db..d37568b1b 100644
--- a/web/Makefile
+++ b/web/Makefile
@@ -1,11 +1,17 @@
-all: index.html osx-notes.html README.html INSTALL.html features.html changelog.html examples.html
-
+ALL := index.html osx-notes.html README.html INSTALL.html features.html changelog.html examples.html
PANDOC_PATH ?= $(dir $(shell which pandoc))
MAKEPAGE = $(PANDOC_PATH)/pandoc -s -S -B header.html -A footer.html -H css
PANDOC_DEPS = header.html footer.html css
+all : $(ALL)
+
+.PHONY: clean
+clean:
+ for file in $(ALL); do rm $$file; done; \
+ rm -r example*;
+
examples.txt : $(PANDOC_DEPS) mkdemos.sh
- ./mkdemos.sh . $$PANDOC_PATH > $@
+ ./mkdemos.sh . $(PANDOC_PATH) > $@
%.html : %.txt $(PANDOC_DEPS)
$(MAKEPAGE) $< > $@