summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJohannes Schauer <josch@debian.org>2015-10-10 00:55:44 +0200
committerJohannes Schauer <josch@debian.org>2015-10-10 00:55:44 +0200
commita4f43aea0f0af03190e95a431a96722325d8ee9e (patch)
treea780de0e239b4645c0aee1c9d85be7f01f885e73 /setup.py
parenta1959ba9c0c9f3881c3e593e5aef1046750880f2 (diff)
import new upstream version 0.2
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py38
1 files changed, 19 insertions, 19 deletions
diff --git a/setup.py b/setup.py
index 84fc9cf..7d94f95 100644
--- a/setup.py
+++ b/setup.py
@@ -1,38 +1,38 @@
#!/usr/bin/env python
-from distutils.core import setup
+from setuptools import setup
+from pdfrw import __version__ as version
+from pdfrw.py23_diffs import convert_load
setup(
name='pdfrw',
- version='0.1',
+ version=version,
description='PDF file reader/writer library',
- long_description='''
-pdfrw lets you read and write PDF files, including
-compositing multiple pages together (e.g. to do watermarking,
-or to copy an image or diagram from one PDF to another),
-and can output by itself, or in conjunction with reportlab.
-
-pdfrw will faithfully reproduce vector formats without
-rasterization, so the rst2pdf package has used pdfrw
-by default for PDF and SVG images by default since
-March 2010. Several small examples are provided.
-''',
+ long_description=convert_load(open("README.rst", 'rb').read()),
author='Patrick Maupin',
author_email='pmaupin@gmail.com',
- platforms="Independent",
- url='http://code.google.com/p/pdfrw/',
+ platforms='Independent',
+ url='https://github.com/pmaupin/pdfrw',
packages=['pdfrw', 'pdfrw.objects'],
- license="MIT",
+ license='MIT',
classifiers=[
'Development Status :: 4 - Beta',
- 'Environment :: Console',
'Intended Audience :: Developers',
'License :: OSI Approved :: MIT License',
'Operating System :: OS Independent',
'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4',
+
'Topic :: Multimedia :: Graphics :: Graphics Conversion',
'Topic :: Software Development :: Libraries',
- 'Topic :: Utilities'
+ 'Topic :: Text Processing',
+ 'Topic :: Printing',
+ 'Topic :: Utilities',
],
- keywords='pdf vector graphics',
+ keywords='pdf vector graphics PDF nup watermark split join merge',
)