summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py7
1 files changed, 6 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 8beaad3..e0ed5d7 100755
--- a/setup.py
+++ b/setup.py
@@ -2,6 +2,7 @@
# Copyright 2017 Canonical Ltd.
# Licensed under the LGPLv3, see LICENCE file for details.
+import sys
import platform
from setuptools import (
@@ -12,7 +13,8 @@ from setuptools import (
PROJECT_NAME = 'macaroonbakery'
-VERSION = (1, 1, 3)
+# version 1.1.4
+VERSION = (1, 1, 4)
def get_version():
@@ -47,6 +49,9 @@ if len(distribution) == 3 and distribution[2] == 'trusty':
'ndg_httpsclient==0.3.3',
])
+if sys.version_info.major == 2:
+ requirements.append('ipaddress')
+
setup(
name=PROJECT_NAME,