summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorVasudev Kamath <vasudev@copyninja.info>2017-07-23 19:29:28 +0530
committerVasudev Kamath <vasudev@copyninja.info>2017-07-23 19:29:28 +0530
commitc8c528c92913538e3b0d0b8e2b2a575a0ebc3628 (patch)
tree83e5db87693e2922320fccabfa04d23155a83a85 /debian/rules
parent72f0d2cdeaeaff957872a616f23fc3e98a13d737 (diff)
parent02f7a2b8fdc9b741741c36230d55dd79ca2efa0b (diff)
pycryptopp (0.7.1-3) unstable; urgency=medium
* debian/control: + Take over maintenance of package. Closes: bug#859182. Thanks to Ramakrishnan for his contributions. + Mark package as compliant to Debian Policy 4.0.0. + Fix Vcs-* URLs to point to secure versions. + Update homepage field to Tahoe-LAFS project trac. + Make package team maintained and mark myself as uploader. + Build-Depend on python-all-dev and python-pkg-resources. + Drop python-pycryptopp-dbg in favor of automatic -dbgsym package. * Convert debian/rules to use pybuild. * debian/watch: + Covnert watch file format to version 4. + Use Github URL for tracking new version instead of PyPI. * Bump compat level to 9. * debian/copyright file is converted to DEP-5 format. * Add copyright-check script and generate copyright-hints file. * Add lintian-overrides for source with proper documentation. * Add DEP-3 headers to patches. [dgit import unpatched pycryptopp 0.7.1-3]
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules13
1 files changed, 13 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..fbe53bd
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,13 @@
+#! /usr/bin/make -f
+
+export PYBUILD_BUILD_ARGS=--disable-embedded-cryptopp
+export PYBUILD_INSTALL_ARGS=--skip-build --single-version-externally-managed
+export PYBUILD_NAME=pycryptopp
+%:
+ dh $@ --with python2 --buildsystem=pybuild
+
+override_dh_auto_clean:
+ dh_testdir -O--buildsystem=pybuild
+ rm -rf .pybuild/
+ rm -rf dist build build-*
+ find . -name "*\.pyc" -delete