summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules13
1 files changed, 13 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..fbe53bd
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,13 @@
+#! /usr/bin/make -f
+
+export PYBUILD_BUILD_ARGS=--disable-embedded-cryptopp
+export PYBUILD_INSTALL_ARGS=--skip-build --single-version-externally-managed
+export PYBUILD_NAME=pycryptopp
+%:
+ dh $@ --with python2 --buildsystem=pybuild
+
+override_dh_auto_clean:
+ dh_testdir -O--buildsystem=pybuild
+ rm -rf .pybuild/
+ rm -rf dist build build-*
+ find . -name "*\.pyc" -delete