summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Pentchev <roam@debian.org>2023-10-19 22:59:56 +0300
committerPeter Pentchev <roam@debian.org>2023-10-19 22:59:56 +0300
commitbbe7d361a7e25af5b35c73ca266f52f8406937ec (patch)
tree6901d0368525af65bad8dff093370950d1b1c6e4
parentab6138fecdf0a7c71948d70e6c853fd36c519681 (diff)
parent48ab14a7001e266c2be787f198cfd3528443da8b (diff)
Update upstream source from tag 'upstream/0.1.6'
Update to upstream version '0.1.6' with Debian dir ea4d6236e63a90f809fc726f0be4d4fec586a05b
-rw-r--r--PKG-INFO2
-rw-r--r--config/ruff-base/pyproject.toml3
-rw-r--r--config/ruff-most/pyproject.toml64
-rw-r--r--docs/changes.md15
-rw-r--r--docs/index.md2
-rw-r--r--pyproject.toml4
-rw-r--r--requirements/black.txt4
-rw-r--r--requirements/ruff.txt4
-rw-r--r--src/parse_stages/defs.py4
-rw-r--r--tox.ini25
10 files changed, 41 insertions, 86 deletions
diff --git a/PKG-INFO b/PKG-INFO
index 8a1470f..8025e87 100644
--- a/PKG-INFO
+++ b/PKG-INFO
@@ -1,6 +1,6 @@
Metadata-Version: 2.1
Name: parse_stages
-Version: 0.1.5
+Version: 0.1.6
Summary: Parse an expression for selecting stages and tags
Project-URL: Homepage, https://devel.ringlet.net/devel/parse-stages/
Project-URL: Changes, https://devel.ringlet.net/devel/parse-stages/changes/
diff --git a/config/ruff-base/pyproject.toml b/config/ruff-base/pyproject.toml
index 2e41989..cf6f470 100644
--- a/config/ruff-base/pyproject.toml
+++ b/config/ruff-base/pyproject.toml
@@ -29,5 +29,8 @@ lines-after-imports = 2
single-line-exclusions = ["typing"]
[tool.ruff.per-file-ignores]
+# typedload needs to be able to parse these even on Python 3.8
+"src/parse_stages/defs.py" = ["UP006"]
+
# This is a test suite
"unit_tests/**.py" = ["S101"]
diff --git a/config/ruff-most/pyproject.toml b/config/ruff-most/pyproject.toml
deleted file mode 100644
index 07265af..0000000
--- a/config/ruff-most/pyproject.toml
+++ /dev/null
@@ -1,64 +0,0 @@
-# SPDX-FileCopyrightText: Peter Pentchev <roam@ringlet.net>
-# SPDX-License-Identifier: BSD-2-Clause
-
-[tool.ruff]
-extend = "../ruff-base/pyproject.toml"
-# These are all the Ruff 0.0.275 linters.
-select = [
- "A",
- "AIR",
- "ANN",
- "ARG",
- "ASYNC",
- "B",
- "BLE",
- "C4",
- "C90",
- "COM",
- "CPY",
- "D",
- "DJ",
- "DTZ",
- "E",
- "EM",
- "ERA",
- "EXE",
- "F",
- "FA",
- "FBT",
- "FIX",
- "FLY",
- "G",
- "I",
- "ICN",
- "INP",
- "INT",
- "ISC",
- "N",
- "NPY",
- "PD",
- "PERF",
- "PGH",
- "PIE",
- "PL",
- "PT",
- "PTH",
- "PYI",
- "Q",
- "RET",
- "RSE",
- "RUF",
- "S",
- "SIM",
- "SLF",
- "SLOT",
- "T10",
- "T20",
- "TCH",
- "TD",
- "TID",
- "TRY",
- "UP",
- "W",
- "YTT",
-]
diff --git a/docs/changes.md b/docs/changes.md
index fa81927..e7d1f41 100644
--- a/docs/changes.md
+++ b/docs/changes.md
@@ -12,6 +12,18 @@ and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0
## [Unreleased]
+## [0.1.6] - 2023-09-28
+
+### Other changes
+
+- Test suite:
+ - use a pinned version of Ruff to avoid breakage with changes enabled in
+ future versions
+ - use Ruff 0.0.291, add a forgotten deferred annotations import
+ - move the "format" check to the first Tox stage
+ - use black 23.7 or later so it understands "py312" as a supported version
+ - use reuse 2.x with no changes
+
## [0.1.5] - 2023-06-27
### Fixes
@@ -187,7 +199,8 @@ and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0
- First public release.
-[Unreleased]: https://gitlab.com/ppentchev/parse-stages/-/compare/release%2F0.1.5...main
+[Unreleased]: https://gitlab.com/ppentchev/parse-stages/-/compare/release%2F0.1.6...main
+[0.1.6]: https://gitlab.com/ppentchev/parse-stages/-/compare/release%2F0.1.5...release%2F0.1.6
[0.1.5]: https://gitlab.com/ppentchev/parse-stages/-/compare/release%2F0.1.4...release%2F0.1.5
[0.1.4]: https://gitlab.com/ppentchev/parse-stages/-/compare/release%2F0.1.3...release%2F0.1.4
[0.1.3]: https://gitlab.com/ppentchev/parse-stages/-/compare/release%2F0.1.2...release%2F0.1.3
diff --git a/docs/index.md b/docs/index.md
index 01a59e1..5231dad 100644
--- a/docs/index.md
+++ b/docs/index.md
@@ -26,7 +26,7 @@ section.
A program that uses the `parse-stages` library should specify it in
its list of requirements, e.g. using [PEP508][pep508] syntax:
- parse-stages >= 0.1.5, < 0.2
+ parse-stages >= 0.1.6, < 0.2
[pep508]: https://peps.python.org/pep-0508/ "PEP 508 – Dependency specification for Python Software Packages"
diff --git a/pyproject.toml b/pyproject.toml
index 9c9c34a..518f309 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -57,11 +57,11 @@ files = ["requirements/install.txt"]
path = "src/parse_stages/defs.py"
[tool.black]
-target-version = ["py38", "py39", "py310", "py311"]
+target-version = ["py38", "py39", "py310", "py311", "py312"]
line-length = 100
[tool.mypy]
strict = true
[tool.test-stages]
-stages = ["ruff and not @manual", "@check and not @manual", "@tests and not @manual"]
+stages = ["@check and @quick and not @manual", "@check and not @manual", "@tests and not @manual"]
diff --git a/requirements/black.txt b/requirements/black.txt
new file mode 100644
index 0000000..e64a1a5
--- /dev/null
+++ b/requirements/black.txt
@@ -0,0 +1,4 @@
+# SPDX-FileCopyrightText: Peter Pentchev <roam@ringlet.net>
+# SPDX-License-Identifier: BSD-2-Clause
+
+black >= 23.7, < 24
diff --git a/requirements/ruff.txt b/requirements/ruff.txt
new file mode 100644
index 0000000..d45867f
--- /dev/null
+++ b/requirements/ruff.txt
@@ -0,0 +1,4 @@
+# SPDX-FileCopyrightText: Peter Pentchev <roam@ringlet.net>
+# SPDX-License-Identifier: BSD-2-Clause
+
+ruff == 0.0.291
diff --git a/src/parse_stages/defs.py b/src/parse_stages/defs.py
index 7134f4e..f3d2ce5 100644
--- a/src/parse_stages/defs.py
+++ b/src/parse_stages/defs.py
@@ -2,6 +2,8 @@
# SPDX-License-Identifier: BSD-2-Clause
"""Common definitions for the parse-stages library."""
+from __future__ import annotations
+
import dataclasses
from typing import List
@@ -42,4 +44,4 @@ class Tagged:
return [self.name]
-VERSION = "0.1.5"
+VERSION = "0.1.6"
diff --git a/tox.ini b/tox.ini
index d817fed..52f76d2 100644
--- a/tox.ini
+++ b/tox.ini
@@ -5,7 +5,6 @@
minversion = 4.1
envlist =
ruff
- ruff-all
format
mypy
unit-tests
@@ -20,17 +19,10 @@ pyfiles =
skip_install = True
tags =
check
+ ruff
+ quick
deps =
- ruff >= 0.0.275, < 0.1
-commands =
- ruff check --config config/ruff-most/pyproject.toml -- {[defs]pyfiles}
-
-[testenv:ruff-all]
-skip_install = True
-tags =
- check
-deps =
- ruff == 0.0.275
+ -r requirements/ruff.txt
commands =
ruff check --config config/ruff-all/pyproject.toml -- {[defs]pyfiles}
@@ -38,9 +30,10 @@ commands =
skip_install = True
tags =
check
+ quick
deps =
- black >= 23, < 24
- ruff >= 0.0.275, < 0.1
+ -r requirements/black.txt
+ -r requirements/ruff.txt
commands =
ruff check --config config/ruff-base/pyproject.toml --select=I --diff -- {[defs]pyfiles}
black --check {[defs]pyfiles}
@@ -51,8 +44,8 @@ tags =
format
manual
deps =
- black >= 23, < 24
- ruff >= 0.0.275, < 0.1
+ -r requirements/black.txt
+ -r requirements/ruff.txt
commands =
ruff check --config config/ruff-base/pyproject.toml --select=I --fix -- {[defs]pyfiles}
black {[defs]pyfiles}
@@ -106,6 +99,6 @@ skip_install = True
tags =
check
deps =
- reuse >= 1, < 2
+ reuse >= 2, < 3
commands =
reuse lint