summaryrefslogtreecommitdiff
path: root/debian/control
diff options
context:
space:
mode:
Diffstat (limited to 'debian/control')
-rw-r--r--debian/control65
1 files changed, 65 insertions, 0 deletions
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..07eb912
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,65 @@
+Source: python-priority
+Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
+Uploaders: Andrej Shadura <andrewsh@debian.org>
+Section: python
+Priority: optional
+Rules-Requires-Root: no
+Build-Depends:
+ debhelper (>= 11),
+ dh-python,
+ python-all (>= 2.6.6-3),
+ python-setuptools (>= 0.6b3),
+ python3-all,
+ python3-setuptools
+Standards-Version: 4.2.0
+Homepage: https://python-hyper.org/priority/
+Vcs-Git: https://git.dgit.debian.org/python-priority
+Vcs-Browser: https://browse.dgit.debian.org/python-priority.git/
+
+Package: python-priority
+Architecture: all
+Depends: ${misc:Depends}, ${python:Depends}
+Description: pure-Python implementation of the HTTP/2 priority tree (Python 2)
+ Priority is a pure-Python implementation of the priority logic for HTTP/2, set
+ out in RFC 7540 Section 5.3 (Stream Priority). This logic allows for clients
+ to express a preference for how the server allocates its (limited) resources to
+ the many outstanding HTTP requests that may be running over a single HTTP/2
+ connection.
+ .
+ Specifically, this Python implementation uses a variant of the implementation
+ used in the H2O project. This original implementation is also the
+ inspiration for nghttp2's priority implementation, and generally produces a
+ very clean and even priority stream. The only notable changes from H2O's
+ implementation are small modifications to allow the priority implementation to
+ work cleanly as a separate implementation, rather than being embedded in a
+ HTTP/2 stack directly.
+ .
+ While priority information in HTTP/2 is only a suggestion, rather than an
+ enforceable constraint, where possible servers should respect the priority
+ requests of their clients.
+ .
+ This package is for Python 2.
+
+Package: python3-priority
+Architecture: all
+Depends: ${misc:Depends}, ${python3:Depends}
+Description: pure-Python implementation of the HTTP/2 priority tree (Python 3)
+ Priority is a pure-Python implementation of the priority logic for HTTP/2, set
+ out in RFC 7540 Section 5.3 (Stream Priority). This logic allows for clients
+ to express a preference for how the server allocates its (limited) resources to
+ the many outstanding HTTP requests that may be running over a single HTTP/2
+ connection.
+ .
+ Specifically, this Python implementation uses a variant of the implementation
+ used in the H2O project. This original implementation is also the
+ inspiration for nghttp2's priority implementation, and generally produces a
+ very clean and even priority stream. The only notable changes from H2O's
+ implementation are small modifications to allow the priority implementation to
+ work cleanly as a separate implementation, rather than being embedded in a
+ HTTP/2 stack directly.
+ .
+ While priority information in HTTP/2 is only a suggestion, rather than an
+ enforceable constraint, where possible servers should respect the priority
+ requests of their clients.
+ .
+ This package is for Python 3.