summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorAlessio Treglia <alessio@debian.org>2013-02-10 10:18:21 +0000
committerAlessio Treglia <alessio@debian.org>2013-02-10 10:18:21 +0000
commit038de1a143b9775f37d4848f52c59af7cee66e36 (patch)
tree8d10a35c194be220b6cb2d1b2982546dbcef9480 /Makefile
parent69d32924ffbfe2bb05d881a23af13b6070b9a9bd (diff)
Imported Upstream version 0.8.3
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 56f7a36..b5f24c5 100644
--- a/Makefile
+++ b/Makefile
@@ -64,14 +64,27 @@ install: src/smplayer
-install -d $(DESTDIR)$(SHORTCUTS_PATH)
cp src/shortcuts/* $(DESTDIR)$(SHORTCUTS_PATH)
+# -install -d $(DESTDIR)$(THEMES_PATH)
+# -tar -C src/themes/ --exclude=.svn -c -f - . | tar -C $(DESTDIR)$(THEMES_PATH) -x -f -
+
+ -install -d $(DESTDIR)$(KDE_ICONS)/512x512/apps/
+ -install -d $(DESTDIR)$(KDE_ICONS)/256x256/apps/
+ -install -d $(DESTDIR)$(KDE_ICONS)/192x192/apps/
+ -install -d $(DESTDIR)$(KDE_ICONS)/128x128/apps/
-install -d $(DESTDIR)$(KDE_ICONS)/64x64/apps/
-install -d $(DESTDIR)$(KDE_ICONS)/32x32/apps/
-install -d $(DESTDIR)$(KDE_ICONS)/22x22/apps/
-install -d $(DESTDIR)$(KDE_ICONS)/16x16/apps/
+ -install -d $(DESTDIR)$(KDE_ICONS)/scalable/apps/
+ install -m 644 icons/smplayer_icon512.png $(DESTDIR)$(KDE_ICONS)/512x512/apps/smplayer.png
+ install -m 644 icons/smplayer_icon256.png $(DESTDIR)$(KDE_ICONS)/256x256/apps/smplayer.png
+ install -m 644 icons/smplayer_icon192.png $(DESTDIR)$(KDE_ICONS)/192x192/apps/smplayer.png
+ install -m 644 icons/smplayer_icon128.png $(DESTDIR)$(KDE_ICONS)/128x128/apps/smplayer.png
install -m 644 icons/smplayer_icon64.png $(DESTDIR)$(KDE_ICONS)/64x64/apps/smplayer.png
install -m 644 icons/smplayer_icon32.png $(DESTDIR)$(KDE_ICONS)/32x32/apps/smplayer.png
install -m 644 icons/smplayer_icon22.png $(DESTDIR)$(KDE_ICONS)/22x22/apps/smplayer.png
install -m 644 icons/smplayer_icon16.png $(DESTDIR)$(KDE_ICONS)/16x16/apps/smplayer.png
+ install -m 644 icons/smplayer.svg $(DESTDIR)$(KDE_ICONS)/scalable/apps/smplayer.svg
-install -d $(DESTDIR)$(KDE_APPLNK)
install -m 644 smplayer.desktop $(DESTDIR)$(KDE_APPLNK)
install -m 644 smplayer_enqueue.desktop $(DESTDIR)$(KDE_APPLNK)