summaryrefslogtreecommitdiff
path: root/docs/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2013-11-15 12:41:32 +0100
committerMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2013-11-15 12:41:32 +0100
commit4a04d07dcfbb7058af70aebbbe5ef57dbe9f33f1 (patch)
tree22c95948251fd681aa769d7213e544b0047e49ff /docs/CMakeLists.txt
parent5d868f93afed068bca90f13e7aca2416ab5fdaeb (diff)
Generate manual without configuring conf.py
Diffstat (limited to 'docs/CMakeLists.txt')
-rw-r--r--docs/CMakeLists.txt9
1 files changed, 1 insertions, 8 deletions
diff --git a/docs/CMakeLists.txt b/docs/CMakeLists.txt
index ab90d6e..b67b537 100644
--- a/docs/CMakeLists.txt
+++ b/docs/CMakeLists.txt
@@ -12,21 +12,14 @@ if(SPHINX)
set(output_dir ${CMAKE_CURRENT_BINARY_DIR}/manual)
file(GLOB_RECURSE sphinx_source ${input_dir}/*.rst)
- list(APPEND sphinx_source "${output_dir}/conf.py")
-
- set(sphinx_static
- _static/ufo-logo.png)
-
- configure_file(${input_dir}/conf.py.in ${output_dir}/conf.py)
foreach(file ${sphinx_static})
configure_file(${input_dir}/${file} ${output_dir}/${file} COPYONLY)
endforeach()
add_custom_command(OUTPUT ${output_dir}/html/index.html
- COMMAND ${SPHINX} -b html -c ${output_dir} ${input_dir} html
+ COMMAND ${SPHINX} -b html ${input_dir} ${output_dir}
DEPENDS ${sphinx_source}
- WORKING_DIRECTORY ${output_dir}
COMMENT "Build Sphinx HTML")
add_custom_target(manual ALL DEPENDS ${output_dir}/html/index.html)