summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorVadim Mikhailov <mvp@users.noreply.github.com>2017-09-19 20:09:49 -0700
committerVadim Mikhailov <mvp@users.noreply.github.com>2017-09-19 20:17:29 -0700
commit63122bacb531f01c4c3589b36417580fa09428bd (patch)
tree697d7ec79b5e2b1e3a98fe21cf851289cb0a3af4 /Makefile
parent047bb1e392efd3e0ea5d5caf351e20761e12cd44 (diff)
Use program version from git tag
This should fix issue #51.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index ce19e70..7074cbf 100644
--- a/Makefile
+++ b/Makefile
@@ -14,6 +14,8 @@ RM := rm -rf
CC ?= gcc
CFLAGS ?= -g -O0
CFLAGS += -Wall -Wextra -std=c99 -pedantic
+GIT_VERSION := $(shell git describe --abbrev=4 --dirty --always --tags)
+CFLAGS += -DPROGRAM_VERSION=\"$(GIT_VERSION)\"
ifeq ($(UNAME_S),Linux)
LDFLAGS += -Wl,-z,relro -lusb-1.0