summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..7ae9575
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,9 @@
+CFLAGS = -g -O0
+LDFLAGS = -lusb-1.0
+PROGRAM = uhubctl
+
+$(PROGRAM): $(PROGRAM).o
+ cc $(CFLAGS) $@.c -o $@ $(LDFLAGS)
+
+clean:
+ rm -rf $(PROGRAM).o $(PROGRAM).dSYM $(PROGRAM)