summaryrefslogtreecommitdiff
path: root/include/ulogd
diff options
context:
space:
mode:
authorChris Boot <bootc@bootc.net>2014-04-13 09:09:51 +0100
committerChris Boot <bootc@bootc.net>2014-04-13 09:09:51 +0100
commit9a9652336fc611b3b94c7b43350b591f000dec56 (patch)
tree8cc826dd3c4a9497a4169bc637eb44dddef10149 /include/ulogd
parent4e3420a2661d9e5ef0941662f166e831010ff5c3 (diff)
parent4ea3022bbe1a71cb50178224ab8192b8cb565ffe (diff)
Imported Upstream version 2.0.4
Diffstat (limited to 'include/ulogd')
-rw-r--r--include/ulogd/Makefile.in5
-rw-r--r--include/ulogd/db.h2
-rw-r--r--include/ulogd/printpkt.h1
-rw-r--r--include/ulogd/ulogd.h4
4 files changed, 9 insertions, 3 deletions
diff --git a/include/ulogd/Makefile.in b/include/ulogd/Makefile.in
index 049f389..33cf63f 100644
--- a/include/ulogd/Makefile.in
+++ b/include/ulogd/Makefile.in
@@ -1,4 +1,4 @@
-# Makefile.in generated by automake 1.14 from Makefile.am.
+# Makefile.in generated by automake 1.14.1 from Makefile.am.
# @configure_input@
# Copyright (C) 1994-2013 Free Software Foundation, Inc.
@@ -250,7 +250,10 @@ install_sh = @install_sh@
libdir = @libdir@
libdl_LIBS = @libdl_LIBS@
libexecdir = @libexecdir@
+libjansson_CFLAGS = @libjansson_CFLAGS@
+libjansson_LIBS = @libjansson_LIBS@
libpcap_LIBS = @libpcap_LIBS@
+libpthread_LIBS = @libpthread_LIBS@
libsqlite3_CFLAGS = @libsqlite3_CFLAGS@
libsqlite3_LIBS = @libsqlite3_LIBS@
localedir = @localedir@
diff --git a/include/ulogd/db.h b/include/ulogd/db.h
index e9b054b..9f9e96d 100644
--- a/include/ulogd/db.h
+++ b/include/ulogd/db.h
@@ -65,7 +65,7 @@ struct db_instance {
#define TIME_ERR ((time_t)-1) /* Be paranoid */
#define RECONNECT_DEFAULT 2
#define MAX_ONESHOT_REQUEST 10
-#define RING_BUFFER_DEFAULT_SIZE 10
+#define RING_BUFFER_DEFAULT_SIZE 0
#define DB_CES \
{ \
diff --git a/include/ulogd/printpkt.h b/include/ulogd/printpkt.h
index a11ce4a..5f9c57c 100644
--- a/include/ulogd/printpkt.h
+++ b/include/ulogd/printpkt.h
@@ -3,7 +3,6 @@
enum pkt_keys {
KEY_OOB_FAMILY,
- KEY_OOB_TIME_SEC,
KEY_OOB_PREFIX,
KEY_OOB_IN,
KEY_OOB_OUT,
diff --git a/include/ulogd/ulogd.h b/include/ulogd/ulogd.h
index 90272eb..cf26a15 100644
--- a/include/ulogd/ulogd.h
+++ b/include/ulogd/ulogd.h
@@ -17,6 +17,7 @@
#include <stdio.h>
#include <signal.h> /* need this because of extension-sighandler */
#include <sys/types.h>
+#include <inttypes.h>
#include <string.h>
#include <config.h>
@@ -97,6 +98,9 @@ struct ulogd_key {
u_int16_t field_id;
} ipfix;
+ /* Store field name for Common Information Model */
+ char *cim_name;
+
union {
/* and finally the returned value */
union {