summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Streetman <dan.streetman@canonical.com>2017-05-29 18:13:27 -0400
committerDan Streetman <dan.streetman@canonical.com>2017-05-29 18:13:27 -0400
commit11e02c1c3f7c246a8e6ded4d22e8e2ce42a1b214 (patch)
tree2922a2085189a1a4d318d5d5b989d4512b18c6b9
parent216ae002ceb7335e008921a1e3b8b49153950a5a (diff)
Import Debian changes 1.9-3.2ubuntu4
vlan (1.9-3.2ubuntu4) artful; urgency=medium * Correct previous patch, to work for ifupdown configuration where a vlan is configured but the vlan's raw device has no ifupdown config. (LP: #1573272)
-rw-r--r--debian/changelog8
-rw-r--r--debian/network/if-pre-up.d/vlan4
2 files changed, 11 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index df7abc9..393b76e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+vlan (1.9-3.2ubuntu4) artful; urgency=medium
+
+ * Correct previous patch, to work for ifupdown configuration where a
+ vlan is configured but the vlan's raw device has no ifupdown config.
+ (LP: #1573272)
+
+ -- Dan Streetman <dan.streetman@canonical.com> Mon, 29 May 2017 18:13:27 -0400
+
vlan (1.9-3.2ubuntu3) artful; urgency=medium
* In vlan ifupdown pre-up script, instead of calling ip link up for
diff --git a/debian/network/if-pre-up.d/vlan b/debian/network/if-pre-up.d/vlan
index 2262e6c..c266e5b 100644
--- a/debian/network/if-pre-up.d/vlan
+++ b/debian/network/if-pre-up.d/vlan
@@ -60,7 +60,9 @@ if [ -n "$IF_VLAN_RAW_DEVICE" ] && [ ! -d /sys/class/net/$IFACE ]; then
exit 1
fi
if [ ! -e "/sys/class/net/$IFACE" ]; then
- ifup $IF_VLAN_RAW_DEVICE
+ # Try ifup for the raw device, if it fails then bring it up directly
+ # this is required e.g. there is no configuration for the raw device
+ ifup $IF_VLAN_RAW_DEVICE || ip link set up dev $IF_VLAN_RAW_DEVICE
vconfig add $IF_VLAN_RAW_DEVICE $VLANID
fi
fi