summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Streetman <dan.streetman@canonical.com>2017-03-30 09:16:10 -0400
committerDan Streetman <dan.streetman@canonical.com>2017-03-30 09:16:10 -0400
commit216ae002ceb7335e008921a1e3b8b49153950a5a (patch)
tree50e4bf069bb43e29289e02e89ff02c8e8635ff04
parent6152215fd415fe09a54483bdf0582b2f17532ea7 (diff)
Import Debian changes 1.9-3.2ubuntu3
vlan (1.9-3.2ubuntu3) artful; urgency=medium * In vlan ifupdown pre-up script, instead of calling ip link up for raw device before creating vlan interface, do a full ifup for raw device. Otherwise, if raw device processes ifup after vlan device, the raw device may be taken down and back up, which removes all vlan routes and other configuration. (LP: #1573272)
-rw-r--r--debian/changelog10
-rw-r--r--debian/network/if-pre-up.d/vlan2
2 files changed, 11 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 706a89c..df7abc9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+vlan (1.9-3.2ubuntu3) artful; urgency=medium
+
+ * In vlan ifupdown pre-up script, instead of calling ip link up for
+ raw device before creating vlan interface, do a full ifup for raw
+ device. Otherwise, if raw device processes ifup after vlan device,
+ the raw device may be taken down and back up, which removes all vlan
+ routes and other configuration. (LP: #1573272)
+
+ -- Dan Streetman <dan.streetman@canonical.com> Thu, 30 Mar 2017 09:16:10 -0400
+
vlan (1.9-3.2ubuntu2) yakkety; urgency=medium
* If VLAN is configured with higher MTU than raw device MTU, which can
diff --git a/debian/network/if-pre-up.d/vlan b/debian/network/if-pre-up.d/vlan
index f4d1877..2262e6c 100644
--- a/debian/network/if-pre-up.d/vlan
+++ b/debian/network/if-pre-up.d/vlan
@@ -60,7 +60,7 @@ if [ -n "$IF_VLAN_RAW_DEVICE" ] && [ ! -d /sys/class/net/$IFACE ]; then
exit 1
fi
if [ ! -e "/sys/class/net/$IFACE" ]; then
- ip link set up dev $IF_VLAN_RAW_DEVICE
+ ifup $IF_VLAN_RAW_DEVICE
vconfig add $IF_VLAN_RAW_DEVICE $VLANID
fi
fi