summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Streetman <dan.streetman@canonical.com>2016-09-08 12:47:31 -0400
committerDan Streetman <dan.streetman@canonical.com>2016-09-08 12:47:31 -0400
commit6152215fd415fe09a54483bdf0582b2f17532ea7 (patch)
tree80767c5af4480c0168c7c6ddbb08d9d483f53fe6
parenta9a384f4f61cbc0b864eec13ceac40f7987f7a43 (diff)
Import Debian changes 1.9-3.2ubuntu2
vlan (1.9-3.2ubuntu2) yakkety; urgency=medium * If VLAN is configured with higher MTU than raw device MTU, which can happen if VLAN is ifup'ed before raw device, then increase raw device MTU first so the VLAN ifup does not fail. (LP: #1224007)
-rw-r--r--debian/changelog8
-rw-r--r--debian/network/if-pre-up.d/vlan8
2 files changed, 16 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 7a22d66..706a89c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+vlan (1.9-3.2ubuntu2) yakkety; urgency=medium
+
+ * If VLAN is configured with higher MTU than raw device MTU, which can
+ happen if VLAN is ifup'ed before raw device, then increase raw device
+ MTU first so the VLAN ifup does not fail. (LP: #1224007)
+
+ -- Dan Streetman <dan.streetman@canonical.com> Thu, 08 Sep 2016 12:47:31 -0400
+
vlan (1.9-3.2ubuntu1) utopic; urgency=medium
* Merge from Debian unstable. Remaining changes:
diff --git a/debian/network/if-pre-up.d/vlan b/debian/network/if-pre-up.d/vlan
index e61566c..f4d1877 100644
--- a/debian/network/if-pre-up.d/vlan
+++ b/debian/network/if-pre-up.d/vlan
@@ -43,6 +43,14 @@ case "$IFACE" in
;;
esac
+if [ -n "$IF_MTU" -a -n "$IF_VLAN_RAW_DEVICE" ]; then
+ CUR_DEV_MTU=`cat /sys/class/net/$IF_VLAN_RAW_DEVICE/mtu`
+ # increase the vlan raw device mtu if needed
+ if [ -n "$CUR_DEV_MTU" ] && [ $CUR_DEV_MTU -lt $IF_MTU ]; then
+ ip link set dev $IF_VLAN_RAW_DEVICE mtu $IF_MTU
+ fi
+fi
+
if [ -n "$IF_VLAN_RAW_DEVICE" ] && [ ! -d /sys/class/net/$IFACE ]; then
if [ ! -x /sbin/vconfig ]; then
exit 0