summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStéphane Graber <stgraber@ubuntu.com>2014-05-02 18:21:06 -0400
committerAndrew Shadura <andrew.shadura@collabora.co.uk>2017-11-26 10:39:03 +0000
commita9a384f4f61cbc0b864eec13ceac40f7987f7a43 (patch)
treec8e762de5870871bb8bd4c5ae52e151efb0150e0
parentc8a07d63a49fda0f763e8a7888d85c0728b8a850 (diff)
parent7517228145310a29b7cb7f4bddccb1b70df347eb (diff)
Merge from Debian unstable.
Remaining changes: - Add a udeb for vconfig in debian-installer. - Add support for biosdevname - Revert ifupdown integration as event based bringup is currently incompatible with the way ifupdown sets up bridges and vlans. - Add udev hook and script for event based bring up.
-rw-r--r--debian/changelog27
-rw-r--r--debian/network/if-pre-up.d/vlan6
2 files changed, 31 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 4c8e812..7a22d66 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,30 @@
+vlan (1.9-3.2ubuntu1) utopic; urgency=medium
+
+ * Merge from Debian unstable. Remaining changes:
+ - Add a udeb for vconfig in debian-installer.
+ - Add support for biosdevname
+ - Revert ifupdown integration as event based bringup is currently
+ incompatible with the way ifupdown sets up bridges and vlans.
+ - Add udev hook and script for event based bring up.
+
+ -- Stéphane Graber <stgraber@ubuntu.com> Fri, 02 May 2014 18:21:06 -0400
+
+vlan (1.9-3.2) unstable; urgency=medium
+
+ * Non-maintainer upload.
+ * Don't exit when we're called by bridge-utils.
+
+ -- Andrew Shadura <andrewsh@debian.org> Tue, 01 Apr 2014 09:42:56 +0200
+
+vlan (1.9-3.1) unstable; urgency=medium
+
+ * Non-maintainer upload.
+ * Don't act on VLAN interfaces already supported by ifupdown
+ (Closes: #705456)
+ * Don't depend on iproute, depend on iproute2 instead.
+
+ -- Andrew Shadura <andrewsh@debian.org> Sun, 23 Mar 2014 14:42:43 +0100
+
vlan (1.9-3ubuntu10) trusty; urgency=medium
* Only create VLANs for the interface we are processing. (LP: #1295371)
diff --git a/debian/network/if-pre-up.d/vlan b/debian/network/if-pre-up.d/vlan
index 15bb746..e61566c 100644
--- a/debian/network/if-pre-up.d/vlan
+++ b/debian/network/if-pre-up.d/vlan
@@ -51,8 +51,10 @@ if [ -n "$IF_VLAN_RAW_DEVICE" ] && [ ! -d /sys/class/net/$IFACE ]; then
echo "$IF_VLAN_RAW_DEVICE does not exist, unable to create $IFACE"
exit 1
fi
- ip link set up dev $IF_VLAN_RAW_DEVICE
- vconfig add $IF_VLAN_RAW_DEVICE $VLANID
+ if [ ! -e "/sys/class/net/$IFACE" ]; then
+ ip link set up dev $IF_VLAN_RAW_DEVICE
+ vconfig add $IF_VLAN_RAW_DEVICE $VLANID
+ fi
fi
# This is not vlan specific, and should actually go somewhere else.