summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorReinhard Tartler <siretart@tauware.de>2019-08-08 15:59:02 +0200
committerAndrej Shadura <andrewsh@debian.org>2019-08-08 15:59:02 +0200
commit05fd0494808527693a49045e3c26a8812005f9fb (patch)
tree9ec2007111c0c3d463153435f25f7cd2ee0bbe83
parent7ca1a572007b12bd3695b7956959e3f46f48858a (diff)
Use pkg-config for libpcsclite linkage flags
At least in debian, we can rely on pkg-config being available and returning more accurate ldflags. Gbp-Pq: Name 01_use_pkg-config_for_pcsc-lite_module.patch
-rw-r--r--wpa_supplicant/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/wpa_supplicant/Makefile b/wpa_supplicant/Makefile
index f1384d5..98ac987 100644
--- a/wpa_supplicant/Makefile
+++ b/wpa_supplicant/Makefile
@@ -1017,7 +1017,7 @@ else
ifdef CONFIG_OSX
LIBS += -framework PCSC
else
-LIBS += -lpcsclite -lpthread
+LIBS += $(shell $(PKG_CONFIG) --libs libpcsclite)
endif
endif
endif