summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2012-01-10 00:11:30 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2012-01-10 00:11:30 +0000
commit460cb92246fa25d21d7d8723136ced515bfd5749 (patch)
tree9abd914610bb3750773327c6ee324226069d6bfc
parentea6c6254fafab598243520b41ae5e94d2e19dd60 (diff)
fix wide characters; tested iso10646
-rw-r--r--Makefile1
-rw-r--r--TODO6
-rw-r--r--bad/12x13ja.pcf.gzbin0 -> 360337 bytes
-rw-r--r--manual/Trad,12,13,0,-2.rules8
-rw-r--r--specs3
-rwxr-xr-xupdate-xfonts-traditional3
6 files changed, 13 insertions, 8 deletions
diff --git a/Makefile b/Makefile
index 16ea0ae..8e27113 100644
--- a/Makefile
+++ b/Makefile
@@ -11,6 +11,7 @@ default: all
all:
./mkrules <specs
+ cp manual/*.rules rules/
install:
perl -pe 's#^(our \$$prefix=").*("\;\s*)$$#$$1$(prefix)$$2#' \
diff --git a/TODO b/TODO
index e3b28cf..e411b3d 100644
--- a/TODO
+++ b/TODO
@@ -1,7 +1 @@
--trad-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso10646-1
- is missing the proper quotes
- fixed I think
-
Need to somehow fix up xterm to use the new font
-
-wide fonts
diff --git a/bad/12x13ja.pcf.gz b/bad/12x13ja.pcf.gz
new file mode 100644
index 0000000..6c827d0
--- /dev/null
+++ b/bad/12x13ja.pcf.gz
Binary files differ
diff --git a/manual/Trad,12,13,0,-2.rules b/manual/Trad,12,13,0,-2.rules
new file mode 100644
index 0000000..3d26220
--- /dev/null
+++ b/manual/Trad,12,13,0,-2.rules
@@ -0,0 +1,8 @@
+# -*- perl -*-
+sub {
+ if ($props{' 7bit'}) {
+ # bad characters are from 12x13ja.pcf.gz
+ s/^0000;0C00;0600;0100;0000;0000;0000;0000;0000;0000;0000;0000;0000$/0000;0E00;0600;0100;0000;0000;0000;0000;0000;0000;0000;0000;0000/;
+ s/^0000;0C00;0C00;0C00;0800;0000;0000;0000;0000;0000;0000;0000;0000$/0000;0700;0600;0800;0000;0000;0000;0000;0000;0000;0000;0000;0000/;
+ }
+}
diff --git a/specs b/specs
index 0d74307..6919580 100644
--- a/specs
+++ b/specs
@@ -7,8 +7,7 @@ rules Trad
partial a
entire [ ] ( ) { } d42 & W
-verbatim if ($props{'CHARSET_REGISTRY'} =~ m/iso8859|utf|iso10646/i &&
-verbatim $props{'ENCODING'} <= 127) {
+verbatim if ($props{' 7bit'}) {
entire ` '
verbatim }
diff --git a/update-xfonts-traditional b/update-xfonts-traditional
index 5e29133..65d1d08 100755
--- a/update-xfonts-traditional
+++ b/update-xfonts-traditional
@@ -112,6 +112,9 @@ sub processbdf ($$$$) {
$y=0;
$glyph='';
$state='bitmap';
+ $props{' 7bit'}=
+ ($props{'CHARSET_REGISTRY'} =~ m/iso8859|utf|iso10646/i &&
+ $props{'ENCODING'} <= 127);
}
}
print $outbdf $_ or die $!;