summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-04-25 00:08:23 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-04-25 00:08:23 +0100
commit9e6fd8dc8031bc2baeaacceeee96d5cdf62295be (patch)
tree026a9f00150efffa04518321b8f3b7f0229548b0
parent8037a39d870cf37b6c7ba2f55df903d8238d6f31 (diff)
mkrules can consume .bdf.direct, or .sfd files.
-rw-r--r--debian/changelog1
-rwxr-xr-xmkrules17
2 files changed, 17 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index ff719e8..ee5bc67 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,6 +6,7 @@ xfonts-traditional (1.7.2~~iwj) UNRELEASED; urgency=medium
* Process `10x20' too. (It was shifted down a pixel during the
conversion; we don't undo this, yet. So far, we just fix the quotes.)
* Document in Description that we process some other font sizes too.
+ * mkrules can consume .bdf.direct, or .sfd files.
-- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 24 Apr 2016 22:07:21 +0100
diff --git a/mkrules b/mkrules
index 5baa1d6..d16d6b4 100755
--- a/mkrules
+++ b/mkrules
@@ -33,8 +33,23 @@ while read keyword rest; do
pcf)
pcf=$rest
for f in good bad; do
+ in=$f/$pcf.pcf.gz
out=$f/$pcf.bdf
- zcat $f/$pcf.pcf.gz | pcf2bdf >$out
+ if [ -e $in ]; then
+ zcat $in | pcf2bdf >$out
+ elif [ -e "$out.direct" ]; then
+ cp "$out.direct" "$out"
+ elif [ -e "$f/$pcf.sfd" ]; then
+ ./ffconvert.pe "$f/$pcf"
+ # 1. fontforge writes a silly filename
+ # 2. our crappy machinery copes only
+ # with BDFs from pcf2bdf, not from
+ # fontforge
+ bdftopcf <"$f/$pcf".BDF*.bdf |pcf2bdf >$out
+ else
+ echo >&2 "cannot make $out!"
+ exit 1
+ fi
eval "$f=\$out"
done
;;