summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2018-10-17 08:40:22 +0200
committerRuben Undheim <ruben.undheim@gmail.com>2019-03-31 00:01:48 +0100
commit881de4ade627dcdde614240e7118ffd4cf18c93c (patch)
treec61e4380f8579b14b2d95efaafa6ab968b7cb49d
parent8580f3e83eedcee12b5a17898be770468e34f2bf (diff)
Let dpkg-buildpackage handle stripping of binariesarchive/debian/0.8+20190328git32bd0f2-1_exp1
Gbp-Pq: Name 0013-Let-dpkg-buildpackage-handle-stripping-of-binaries.patch
-rw-r--r--Makefile4
1 files changed, 0 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 2ed9f0fc..b4aac539 100644
--- a/Makefile
+++ b/Makefile
@@ -625,19 +625,15 @@ install: $(TARGETS) $(EXTRA_TARGETS)
$(INSTALL_SUDO) mkdir -p $(DESTDIR)$(BINDIR)
$(INSTALL_SUDO) cp $(TARGETS) $(DESTDIR)$(BINDIR)
ifneq ($(filter yosys,$(TARGETS)),)
- $(INSTALL_SUDO) $(STRIP) -S $(DESTDIR)$(BINDIR)/yosys
endif
ifneq ($(filter yosys-abc,$(TARGETS)),)
- $(INSTALL_SUDO) $(STRIP) $(DESTDIR)$(BINDIR)/yosys-abc
endif
ifneq ($(filter yosys-filterlib,$(TARGETS)),)
- $(INSTALL_SUDO) $(STRIP) $(DESTDIR)$(BINDIR)/yosys-filterlib
endif
$(INSTALL_SUDO) mkdir -p $(DESTDIR)$(DATDIR)
$(INSTALL_SUDO) cp -r share/. $(DESTDIR)$(DATDIR)/.
ifeq ($(ENABLE_LIBYOSYS),1)
$(INSTALL_SUDO) cp libyosys.so $(DESTDIR)$(LIBDIR)
- $(INSTALL_SUDO) $(STRIP) -S $(DESTDIR)$(LIBDIR)/libyosys.so
$(INSTALL_SUDO) ldconfig
endif