summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSiesh1oo <siesh1oo@siesh1oo.no>2014-03-10 20:06:46 +0100
committerSiesh1oo <siesh1oo@siesh1oo.no>2014-03-13 11:29:03 +0100
commitcb4293624e11d61f64e51027fabc73fbcf504fa2 (patch)
treeda2ff4ede276292c439ee36edb7249de2610d62f
parent89443aadbc6a20270de024f41ae1cc79ec75a8cf (diff)
- Makefile: export PATH=${DESTDIR}/bin:$(PATH) and (DY)LD_LIBRARY_PATH, to make sure our local copies of built executables and libraries are used.
- Makefile: use find expression in target 'yosys-svgviewer' to find svgviewer binary (qmake will build into .app package on OSX). - Makefile: make 'test' target dependent on $(TARGETS) and $(EXTRA_TARGETS) to make sure that minisat is built.
-rw-r--r--Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 8da8b4c5..1bafd217 100644
--- a/Makefile
+++ b/Makefile
@@ -26,13 +26,17 @@ CXXFLAGS = -Wall -Wextra -ggdb -I"$(shell pwd)" -I${DESTDIR}/include -MD -D_YOSY
LDFLAGS = -I${DESTDIR}/lib
LDLIBS = -lstdc++ -lreadline -lm -ldl
+export PATH := ${DESTDIR}/bin:$(PATH)
+
ifeq (Darwin,$(findstring Darwin,$(shell uname)))
# add macports include and library path to search directories, don't use '-rdynamic' and '-lrt':
+ export DYLD_LIBRARY_PATH := ${DESTDIR}/lib:$(DYLD_LIBRARY_PATH)
CXXFLAGS += -I/opt/local/include
LDFLAGS += -L/opt/local/lib
QMAKE = qmake
SED = gsed
else
+ export LD_LIBRARY_PATH := ${DESTDIR}/lib:$(LD_LIBRARY_PATH)
LDFLAGS += -rdynamic
LDLIBS += -lrt
QMAKE = qmake-qt4
@@ -132,7 +136,7 @@ yosys-config: yosys-config.in
yosys-svgviewer: libs/svgviewer/*.h libs/svgviewer/*.cpp
cd libs/svgviewer && $(QMAKE) && make
- cp libs/svgviewer/svgviewer yosys-svgviewer
+ cp `find libs/svgviewer -name svgviewer -type f` yosys-svgviewer
yosys-minisat: $(DESTDIR)/bin/minisat
$(DESTDIR)/bin/minisat: