summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorSebastian Kuzminsky <seb@highlab.com>2016-02-28 15:17:58 -0700
committerSebastian Kuzminsky <seb@highlab.com>2016-03-03 21:44:52 -0700
commitd280e4850c46ddb55b2b007c5baa846bb7ea49c2 (patch)
tree850ca5b158caa8fa0612a45bc9f0c49863e84e1f /debian/rules
parent85acb59508b6d53a5a7eae2a072d81220951ab39 (diff)
add a manpage for yosys-smtbmc
Also add infrastructure for building manpages with txt2man, lifted from fpga-icestorm.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 11 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 3146665e..10dc50d8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,9 +5,20 @@
export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+CHANGELOG_DATE ?= $(shell LC_ALL=C date -u -d "`dpkg-parsechangelog --show-field Date`" +"%d %B %Y")
+
+
%:
PREFIX=/usr dh $@ --parallel
+override_dh_auto_clean:
+ dh_auto_clean
+ $(RM) debian/man/*.1
+
override_dh_auto_configure:
make config-gcc
+
+override_dh_installman:
+ cd debian/man ; CHANGELOG_DATE="$(CHANGELOG_DATE)" ./genmanpages.sh
+ dh_installman