summaryrefslogtreecommitdiff
path: root/passes/techmap/Makefile.inc
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2014-07-31 02:32:00 +0200
committerClifford Wolf <clifford@clifford.at>2014-07-31 02:32:00 +0200
commit1202f7aa4bb0f9afde157ebc4701d64e7e38abd8 (patch)
treed1a4bb9dfe62ac911ca4751a98b3b63dba22af40 /passes/techmap/Makefile.inc
parent6ca0c569d92883b6eac1725204de90aee4af31bc (diff)
Renamed "stdcells.v" to "techmap.v"
Diffstat (limited to 'passes/techmap/Makefile.inc')
-rw-r--r--passes/techmap/Makefile.inc6
1 files changed, 3 insertions, 3 deletions
diff --git a/passes/techmap/Makefile.inc b/passes/techmap/Makefile.inc
index e54c018a..b49259a8 100644
--- a/passes/techmap/Makefile.inc
+++ b/passes/techmap/Makefile.inc
@@ -10,16 +10,16 @@ OBJS += passes/techmap/hilomap.o
OBJS += passes/techmap/extract.o
endif
-GENFILES += passes/techmap/stdcells.inc
+GENFILES += passes/techmap/techmap.inc
-passes/techmap/stdcells.inc: techlibs/common/stdcells.v
+passes/techmap/techmap.inc: techlibs/common/techmap.v
$(P) echo "// autogenerated from $<" > $@.new
$(Q) echo "static char stdcells_code[] = {" >> $@.new
$(Q) od -v -td1 -An $< | $(SED) -e 's/[0-9][0-9]*/&,/g' >> $@.new
$(Q) echo "0};" >> $@.new
$(Q) mv $@.new $@
-passes/techmap/techmap.o: passes/techmap/stdcells.inc
+passes/techmap/techmap.o: passes/techmap/techmap.inc
TARGETS += yosys-filterlib
GENFILES += passes/techmap/filterlib.o