summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuss Allbery <eagle@eyrie.org>2014-04-13 11:15:35 -0700
committerRuss Allbery <eagle@eyrie.org>2014-04-13 11:15:35 -0700
commit6cdb20aa4fb82d744c6c03d53c4805c3918f6aec (patch)
treedb4af184f471bc0cd4b4b82e0b8efa7f659ed042
parent314796fa94e64a85274d24f4990dd1061cab5e65 (diff)
Use dh_autoreconf, enable parallel builds
* Actually use dh_autoreconf rather than only depending on it. Thanks to Matthias Klose for the report. (Closes: #744600) * Enable parallel builds.
-rw-r--r--debian/changelog8
-rwxr-xr-xdebian/rules6
2 files changed, 11 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 0b4743a..cb24b6f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+krb5-sync (3.0-4) unstable; urgency=medium
+
+ * Actually use dh_autoreconf rather than only depending on it. Thanks
+ to Matthias Klose for the report. (Closes: #744600)
+ * Enable parallel builds.
+
+ -- Russ Allbery <rra@debian.org> Sun, 13 Apr 2014 11:14:45 -0700
+
krb5-sync (3.0-3) unstable; urgency=medium
* The change in 3.0-3 fixed the test suite failure on all architectures
diff --git a/debian/rules b/debian/rules
index 232aab3..6162b73 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,14 +6,14 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+bindnow,+pie
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
%:
- dh $@
+ dh $@ --parallel --with autoreconf
override_dh_auto_configure:
- dh_auto_configure -- --enable-reduced-depends \
+ dh_auto_configure --parallel -- --enable-reduced-depends \
--libdir=/usr/lib/$(DEB_HOST_MULTIARCH)
override_dh_auto_install:
- dh_auto_install
+ dh_auto_install --parallel
rm debian/tmp/usr/lib/*/krb5/plugins/kadm5_hook/*.la
chmod 644 debian/tmp/usr/lib/*/krb5/plugins/kadm5_hook/*.so