summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorroktas <roktas@788f1e2b-df1e-0410-8736-df70ead52e1b>2006-10-30 12:15:02 +0000
committerroktas <roktas@788f1e2b-df1e-0410-8736-df70ead52e1b>2006-10-30 12:15:02 +0000
commit1ba9113d7e0541658d90c02ac58198398c161256 (patch)
tree5d6576bf576c40be5329f195002c2a93fba93f3b /Makefile
parent93fe9eecc442eb9168f22b4af30c57868717e0e6 (diff)
Make debian/rules executable to avoid errors in 'distclean' target.
git-svn-id: https://pandoc.googlecode.com/svn/trunk@45 788f1e2b-df1e-0410-8736-df70ead52e1b
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 3cf5fc882..2479b55c6 100644
--- a/Makefile
+++ b/Makefile
@@ -219,7 +219,10 @@ deb: debian
.PHONY: distclean clean
distclean: clean
- if [ -d debian ]; then fakeroot debian/rules clean; fi
+ if [ -d debian ]; then \
+ chmod +x debian/rules; fakeroot debian/rules clean; \
+ fi
+
clean:
-if [ -f $(BUILDCONF) ]; then $(BUILDCMD) clean; fi
-rm -rf $(cleanup_files)