summaryrefslogtreecommitdiff
path: root/cmake/setup.py.in
diff options
context:
space:
mode:
Diffstat (limited to 'cmake/setup.py.in')
-rw-r--r--cmake/setup.py.in24
1 files changed, 24 insertions, 0 deletions
diff --git a/cmake/setup.py.in b/cmake/setup.py.in
new file mode 100644
index 0000000..a5913a2
--- /dev/null
+++ b/cmake/setup.py.in
@@ -0,0 +1,24 @@
+#!/usr/bin/env python
+
+from distutils.core import setup
+
+setup(name='pigpio',
+ version='1.44',
+ author='joan',
+ author_email='joan@abyz.me.uk',
+ maintainer='joan',
+ maintainer_email='joan@abyz.me.uk',
+ url='http://abyz.me.uk/rpi/pigpio/python.html',
+ description='Raspberry Pi GPIO module',
+ long_description='Raspberry Pi Python module to access the pigpio daemon',
+ download_url='http://abyz.me.uk/rpi/pigpio/pigpio.zip',
+ license='unlicense.org',
+ py_modules=['pigpio'],
+ keywords=['raspberrypi', 'gpio',],
+ classifiers=[
+ "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 3",
+ ],
+ package_dir={ '': '${CMAKE_CURRENT_SOURCE_DIR}'}
+ )
+