summaryrefslogtreecommitdiff
path: root/cmake
diff options
context:
space:
mode:
Diffstat (limited to 'cmake')
-rw-r--r--cmake/FindRT.cmake39
-rw-r--r--cmake/pigpioConfig.cmake1
-rw-r--r--cmake/setup.py.in24
3 files changed, 64 insertions, 0 deletions
diff --git a/cmake/FindRT.cmake b/cmake/FindRT.cmake
new file mode 100644
index 0000000..db7c4de
--- /dev/null
+++ b/cmake/FindRT.cmake
@@ -0,0 +1,39 @@
+# FindRT.cmake - Try to find the RT library
+# Once done this will define
+#
+# RT_FOUND - System has rt
+# RT_INCLUDE_DIR - The rt include directory
+# RT_LIBRARIES - The libraries needed to use rt
+# RT_DEFINITIONS - Compiler switches required for using rt
+#
+# Also creates an import target called RT::RT
+
+find_path (RT_INCLUDE_DIR NAMES time.h
+ PATHS
+ /usr
+ /usr/local
+ /opt
+ PATH_SUFFIXES
+)
+
+find_library(RT_LIBRARIES NAMES rt
+ PATHS
+ /usr
+ /usr/local
+ /opt
+)
+
+include(FindPackageHandleStandardArgs)
+
+FIND_PACKAGE_HANDLE_STANDARD_ARGS(rt DEFAULT_MSG RT_LIBRARIES RT_INCLUDE_DIR)
+
+mark_as_advanced(RT_INCLUDE_DIR RT_LIBRARIES)
+
+if (NOT TARGET RT::RT)
+ add_library(RT::RT INTERFACE IMPORTED)
+
+ set_target_properties(RT::RT PROPERTIES
+ INTERFACE_INCLUDE_DIRECTORIES ${RT_INCLUDE_DIR}
+ INTERFACE_LINK_LIBRARIES ${RT_LIBRARIES}
+ )
+endif() \ No newline at end of file
diff --git a/cmake/pigpioConfig.cmake b/cmake/pigpioConfig.cmake
new file mode 100644
index 0000000..7912526
--- /dev/null
+++ b/cmake/pigpioConfig.cmake
@@ -0,0 +1 @@
+include (${CMAKE_CURRENT_LIST_DIR}/pigpioTargets.cmake) \ No newline at end of file
diff --git a/cmake/setup.py.in b/cmake/setup.py.in
new file mode 100644
index 0000000..a5913a2
--- /dev/null
+++ b/cmake/setup.py.in
@@ -0,0 +1,24 @@
+#!/usr/bin/env python
+
+from distutils.core import setup
+
+setup(name='pigpio',
+ version='1.44',
+ author='joan',
+ author_email='joan@abyz.me.uk',
+ maintainer='joan',
+ maintainer_email='joan@abyz.me.uk',
+ url='http://abyz.me.uk/rpi/pigpio/python.html',
+ description='Raspberry Pi GPIO module',
+ long_description='Raspberry Pi Python module to access the pigpio daemon',
+ download_url='http://abyz.me.uk/rpi/pigpio/pigpio.zip',
+ license='unlicense.org',
+ py_modules=['pigpio'],
+ keywords=['raspberrypi', 'gpio',],
+ classifiers=[
+ "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 3",
+ ],
+ package_dir={ '': '${CMAKE_CURRENT_SOURCE_DIR}'}
+ )
+