summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Tille <tille@debian.org>2023-12-11 21:36:05 +0100
committerAndreas Tille <tille@debian.org>2023-12-11 21:36:05 +0100
commita8f5da65d04205b8f6df7661ab6220b2b6a8374e (patch)
treed55b1512f227857753d04db4ef5ea08cf10b2833
parentbe3e4f8c9d227c69f18e3938a4a735eb7c7f38b5 (diff)
parent3ddee7788e94cca6988fe45650679e1056dd401b (diff)
Record pyranges (0.0.111+ds-6) in archive suite sid
-rw-r--r--debian/changelog10
-rw-r--r--debian/control2
-rw-r--r--debian/patches/no_install_depends_cython.patch16
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules2
-rw-r--r--debian/upstream/metadata6
-rw-r--r--setup.py2
7 files changed, 33 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index 9ba27bb..63e3614 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+pyranges (0.0.111+ds-6) unstable; urgency=medium
+
+ * Team upload.
+ * No runtime dependency from cython
+ Closes: #1058012
+ * Build-Depends: s/dh-python/dh-sequence-python3/ (routine-update)
+ * Set upstream metadata fields: Bug-Database, Bug-Submit, Repository-Browse.
+
+ -- Andreas Tille <tille@debian.org> Mon, 11 Dec 2023 21:36:05 +0100
+
pyranges (0.0.111+ds-5) unstable; urgency=medium
* healthcheck-all.patch: new: fix test failure.
diff --git a/debian/control b/debian/control
index 92193c1..ac33189 100644
--- a/debian/control
+++ b/debian/control
@@ -6,7 +6,7 @@ Section: python
Testsuite: autopkgtest-pkg-python
Priority: optional
Build-Depends: debhelper-compat (= 13),
- dh-python,
+ dh-sequence-python3,
python3-setuptools,
python3-all,
python3-ncls <!nocheck>,
diff --git a/debian/patches/no_install_depends_cython.patch b/debian/patches/no_install_depends_cython.patch
new file mode 100644
index 0000000..9a75ab4
--- /dev/null
+++ b/debian/patches/no_install_depends_cython.patch
@@ -0,0 +1,16 @@
+Description: No runtime dependency from cython
+Bug-Debian: https://bugs.debian.org/1058012
+Author: Andreas Tille <tille@debian.org>
+Last-Update: Mon, 11 Dec 2023 10:10:25 +0100
+
+--- a/setup.py
++++ b/setup.py
+@@ -6,7 +6,7 @@ __version__ = open("pyranges/version.py"
+ '"', '').strip()
+
+ install_requires = [
+- "cython", "pandas", "ncls>=0.0.62", "tabulate", "sorted_nearest>=0.0.33", "pyrle",
++ "pandas", "ncls>=0.0.62", "tabulate", "sorted_nearest>=0.0.33", "pyrle",
+ "natsort"] #,
+
+ # optional_requires = ["bamread", "pybigwig", "ray"]
diff --git a/debian/patches/series b/debian/patches/series
index 0a042cc..5259d88 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -2,3 +2,4 @@ fix_dtype.patch
reorder.patch
numpy_1.24.patch
healthcheck-all.patch
+no_install_depends_cython.patch
diff --git a/debian/rules b/debian/rules
index e3b8a81..930701f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,7 +11,7 @@ export PYBUILD_BEFORE_TEST=cp -av {dir}/tests/*.bed {build_dir}/tests && \
export PYBUILD_TEST_ARGS=-n $(shell nproc)
%:
- dh $@ --with python3 --buildsystem=pybuild
+ dh $@ --buildsystem=pybuild
execute_after_dh_auto_build:
echo 'Generating corresponding files ...'
diff --git a/debian/upstream/metadata b/debian/upstream/metadata
index 0463544..66888ef 100644
--- a/debian/upstream/metadata
+++ b/debian/upstream/metadata
@@ -1,7 +1,7 @@
---
Archive: GitHub
-Bug-Database: https://github.com/biocore-ntnu/pyranges/issues
-Bug-Submit: https://github.com/biocore-ntnu/pyranges/issues/new
+Bug-Database: https://github.com/pyranges/pyranges/issues
+Bug-Submit: https://github.com/pyranges/pyranges/issues/new
Changelog: https://github.com/biocore-ntnu/pyranges/tags
Reference:
- Author: Endre Bakken Stovner and Pål Sætrom
@@ -24,4 +24,4 @@ Registry:
- Name: conda:bioconda
Entry: pyranges
Repository: https://github.com/biocore-ntnu/pyranges.git
-Repository-Browse: https://github.com/biocore-ntnu/pyranges
+Repository-Browse: https://github.com/pyranges/pyranges
diff --git a/setup.py b/setup.py
index 5d16179..e2f0f1a 100644
--- a/setup.py
+++ b/setup.py
@@ -6,7 +6,7 @@ __version__ = open("pyranges/version.py").readline().split(" = ")[1].replace(
'"', '').strip()
install_requires = [
- "cython", "pandas", "ncls>=0.0.62", "tabulate", "sorted_nearest>=0.0.33", "pyrle",
+ "pandas", "ncls>=0.0.62", "tabulate", "sorted_nearest>=0.0.33", "pyrle",
"natsort"] #,
# optional_requires = ["bamread", "pybigwig", "ray"]