summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgustavo panizzo <gfa@zumbi.com.ar>2021-04-05 16:33:37 +0200
committergustavo panizzo <gfa@zumbi.com.ar>2021-04-05 16:33:37 +0200
commit296cf882a95f18582cb13da31b6b5bd61bcac6f1 (patch)
tree3227583f45bb2ac3ddf31fe8f331b3d11f886de7
parentcad994e85f7c1df4be23644b1fc2af06265b1289 (diff)
debian-changes
The Debian packaging of uhubctl is maintained in git, using the merging workflow described in dgit-maint-merge(7). There isn't a patch queue that can be represented as a quilt series. A detailed breakdown of the changes is available from their canonical representation - git commits in the packaging repository. For example, to see the changes made by the Debian maintainer in the first upload of upstream version 1.2.3, you could use: % git clone https://git.dgit.debian.org/uhubctl % cd uhubctl % git log --oneline 1.2.3..debian/1.2.3-1 -- . ':!debian' (If you have dgit, use `dgit clone uhubctl`, rather than plain `git clone`.) A single combined diff, containing all the changes, follows. Gbp-Pq: Name debian-changes
-rw-r--r--Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index e71f9aa..fb64fc1 100644
--- a/Makefile
+++ b/Makefile
@@ -15,11 +15,17 @@ PKG_CONFIG ?= pkg-config
CC ?= gcc
CFLAGS ?= -g -O0
CFLAGS += -Wall -Wextra -std=c99 -pedantic
+# Gets the full version of the source package including debian version
+DEB_VERSION := $(shell dpkg-parsechangelog | egrep '^Version:' | cut -f 2 -d ' ')
+DEB_NOEPOCH_VERSION := $(shell echo $(DEB_VERSION) | cut -d: -f2-)
+# Gets only the upstream version of the package
+DEB_UPSTREAM_VERSION := $(shell echo $(DEB_NOEPOCH_VERSION) | sed 's/-[^-]*$$//')
+
+CFLAGS += -DPROGRAM_VERSION=\"$(DEB_VERSION)\"
GIT_VERSION := $(shell git describe --match "v[0-9]*" --abbrev=8 --dirty --tags | cut -c2-)
ifeq ($(GIT_VERSION),)
GIT_VERSION := $(shell cat VERSION)
endif
-CFLAGS += -DPROGRAM_VERSION=\"$(GIT_VERSION)\"
# Use hardening options on Linux
ifeq ($(UNAME_S),Linux)