summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgustavo panizzo <gfa@zumbi.com.ar>2020-05-24 23:58:36 +0200
committergustavo panizzo <gfa@zumbi.com.ar>2020-05-25 00:02:47 +0200
commitd8728d05f9c3ab3d6a7cd7210230fe785c911347 (patch)
tree9745f38427f1e505275afafd767d2e9d7d0bb226
parentad933e9f22f97b1956bfa36efd66818077767a3c (diff)
Remove applied patches to the source code
I'm reverting 36c00680b8c4fe9ff3f6855fa880b05a8e7d536a to have a patches-unapplied master branch Also I'm removing d/patches as documented on dgit-maint-merge(7)
-rw-r--r--Makefile13
-rw-r--r--debian/patches/debian-ways32
-rw-r--r--debian/patches/series1
3 files changed, 5 insertions, 41 deletions
diff --git a/Makefile b/Makefile
index 021d836..f6d69d3 100644
--- a/Makefile
+++ b/Makefile
@@ -14,14 +14,11 @@ RM := rm -rf
CC ?= gcc
CFLAGS ?= -g -O0
CFLAGS += -Wall -Wextra -std=c99 -pedantic
-
-# # Gets the full version of the source package including debian version
-DEB_VERSION := $(shell dpkg-parsechangelog | egrep '^Version:' | cut -f 2 -d ' ')
-DEB_NOEPOCH_VERSION := $(shell echo $(DEB_VERSION) | cut -d: -f2-)
-# # Gets only the upstream version of the package
-DEB_UPSTREAM_VERSION := $(shell echo $(DEB_NOEPOCH_VERSION) | sed 's/-[^-]*$$//')
-
-CFLAGS += -DPROGRAM_VERSION=\"$(DEB_UPSTREAM_VERSION)\"
+GIT_VERSION := $(shell git describe --abbrev=8 --dirty --always --tags)
+ifeq ($(GIT_VERSION),)
+ GIT_VERSION := $(shell cat VERSION)
+endif
+CFLAGS += -DPROGRAM_VERSION=\"$(GIT_VERSION)\"
ifeq ($(UNAME_S),Linux)
LDFLAGS += -Wl,-z,relro -lusb-1.0
diff --git a/debian/patches/debian-ways b/debian/patches/debian-ways
deleted file mode 100644
index 30ee601..0000000
--- a/debian/patches/debian-ways
+++ /dev/null
@@ -1,32 +0,0 @@
-From: gustavo panizzo <gfa@zumbi.com.ar>
-Date: Tue, 31 Jul 2018 10:28:52 +0800
-Subject: debian-ways
-
----
- Makefile | 13 ++++++++-----
- 1 file changed, 8 insertions(+), 5 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index f6d69d3..021d836 100644
---- a/Makefile
-+++ b/Makefile
-@@ -14,11 +14,14 @@ RM := rm -rf
- CC ?= gcc
- CFLAGS ?= -g -O0
- CFLAGS += -Wall -Wextra -std=c99 -pedantic
--GIT_VERSION := $(shell git describe --abbrev=8 --dirty --always --tags)
--ifeq ($(GIT_VERSION),)
-- GIT_VERSION := $(shell cat VERSION)
--endif
--CFLAGS += -DPROGRAM_VERSION=\"$(GIT_VERSION)\"
-+
-+# # Gets the full version of the source package including debian version
-+DEB_VERSION := $(shell dpkg-parsechangelog | egrep '^Version:' | cut -f 2 -d ' ')
-+DEB_NOEPOCH_VERSION := $(shell echo $(DEB_VERSION) | cut -d: -f2-)
-+# # Gets only the upstream version of the package
-+DEB_UPSTREAM_VERSION := $(shell echo $(DEB_NOEPOCH_VERSION) | sed 's/-[^-]*$$//')
-+
-+CFLAGS += -DPROGRAM_VERSION=\"$(DEB_UPSTREAM_VERSION)\"
-
- ifeq ($(UNAME_S),Linux)
- LDFLAGS += -Wl,-z,relro -lusb-1.0
diff --git a/debian/patches/series b/debian/patches/series
deleted file mode 100644
index b2e9488..0000000
--- a/debian/patches/series
+++ /dev/null
@@ -1 +0,0 @@
-debian-ways