summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim Mikhailov <mvp@users.noreply.github.com>2020-12-08 15:09:06 -0800
committerVadim Mikhailov <mvp@users.noreply.github.com>2020-12-08 15:24:41 -0800
commite65d077712a60ec1cf9df6436544c1108bc569a2 (patch)
treebb76cb2e05c4667a1d58043c27dee0f0cb3c1371
parent0cc09299fea01b6d226a7031a378dc8691c3667c (diff)
Do not allow just commit id to be used as version
Homebrew is forcing `--no-tags` for cloned repos. Because we used `git describe --always` brew was choosing raw commit id as version, which is quite bad. By removing `--always` we will use contents of VERSION file as a backup.
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 80f6e0f..071e015 100644
--- a/Makefile
+++ b/Makefile
@@ -14,7 +14,7 @@ RM := rm -rf
CC ?= gcc
CFLAGS ?= -g -O0
CFLAGS += -Wall -Wextra -std=c99 -pedantic
-GIT_VERSION := $(shell git describe --match "v[0-9]*" --abbrev=8 --dirty --always --tags | cut -c2-)
+GIT_VERSION := $(shell git describe --match "v[0-9]*" --abbrev=8 --dirty --tags | cut -c2-)
ifeq ($(GIT_VERSION),)
GIT_VERSION := $(shell cat VERSION)
endif